Increased latency
Incident Report for edX
Resolved
This incident has been resolved.
Posted 7 months ago. Apr 04, 2018 - 16:51 EDT
Investigating
We are experiencing increased latency again. We are investigating this ongoing issue. We apologize for the inconvenience.
Posted 7 months ago. Apr 04, 2018 - 13:35 EDT