Degraded performance on edx.org
Incident Report for edX
Resolved
The degraded performance on edx.org has been resolved.
Posted Aug 26, 2019 - 17:06 EDT
Monitoring
The degraded performance on edx.org has recovered. We are actively monitoring load times on edx.org.
Posted Aug 26, 2019 - 15:49 EDT
Investigating
Course pages on edx.org are experiencing degraded performance. Our engineers are currently investigating. End users may intermittently experience slow page load times, account logouts, or server errors on course pages.
Posted Aug 26, 2019 - 14:55 EDT
This incident affected: Student Courseware.