Intermittent Page Load Issues on edx.org
Incident Report for edX
Resolved
This issue has been resolved.
Posted Jan 23, 2020 - 10:10 EST
Update
Our engineers are continuing to work on a fix for page load issues on edx.org. Users may intermittently experience broken webpage styling. If you encounter an issue, please wait a few minutes and then refresh the page.
Posted Dec 17, 2019 - 12:56 EST
Identified
Our engineers are working on a fix for intermittent page load issues on edx.org. Users may experience broken webpage styling. If you encounter an issue with the appearance of a page, please wait several minutes and then attempt a refresh.
Posted Dec 13, 2019 - 09:52 EST
This incident affected: Course Authoring (Studio) and Student Courseware.