edX.org learning pages down

Incident Report for edX

Resolved

This issue has been resolved and access is restored and stable.
Posted Feb 24, 2025 - 18:05 UTC

Monitoring

The issue has been addressed so some learners may be able to access their coursework. We are continuing to monitor to ensure learner access.
Posted Feb 24, 2025 - 16:43 UTC

Investigating

The learning pages for edX.org are currently down and we are investigating.
Posted Feb 24, 2025 - 16:35 UTC
This incident affected: Student Courseware.