Slowness on courses.edx.org
Incident Report for edX
Resolved
This incident has been resolved and speeds should be back to normal.
Posted 2 months ago. Mar 14, 2019 - 15:24 EDT
Monitoring
A resolution for this issue has been completed and courses.edx.org should no longer be experiences slow downs. We are continuing to monitor performance.
Posted 2 months ago. Mar 14, 2019 - 10:04 EDT
Identified
We have identified the issue and are working on a resolution.
Posted 2 months ago. Mar 14, 2019 - 09:55 EDT
Investigating
We are currently investigating slow downs on courses.edx.org.
Posted 2 months ago. Mar 14, 2019 - 09:49 EDT
This incident affected: Student Courseware.