Degraded performance on edx.org
Incident Report for edX
Resolved
This incident has been resolved.
Posted 15 days ago. Aug 06, 2019 - 16:23 EDT
Identified
Edx.org is experiencing degraded performance. Our engineers are currently investigating. End users may experience slowdowns in courses on edx.org.
Posted 15 days ago. Aug 06, 2019 - 14:54 EDT
This incident affected: Student Courseware.