Issues with Logging into edx.org
Incident Report for edX
Resolved
The issue should now be resolved.
Posted 9 days ago. Aug 08, 2018 - 12:56 EDT
Identified
We are currently experiencing issues with users trying to login to edx.org. We've identified the issue and are making a fix now to resolve the problem.
Posted 9 days ago. Aug 08, 2018 - 12:53 EDT