Insights is under maintenance
Incident Report for edX
Resolved
The maintenance has been completed, thank you for waiting.
Posted Mar 25, 2020 - 13:55 UTC
Investigating
We are currently upgrading instructor analytics and it will be briefly unavailable, we apologize for the inconvenience. It will be back up momentarily.
Posted Mar 25, 2020 - 13:43 UTC
This incident affected: Edge (Edge Instructor Analytics) and Instructor Analytics.