Intermittent Performance Issues on edx.org
Incident Report for edX
Resolved
This incident has been resolved.
Posted Jul 27, 2022 - 17:05 EDT
Update
The intermittent performance issues on edx.org have been resolved.
Posted Jul 27, 2022 - 17:05 EDT
Monitoring
The intermittent issues have recovered. We will continue to actively monitor performance.
Posted Jul 22, 2022 - 15:04 EDT
Investigating
edx.org is currently experiencing intermittent performance issues. Users may experience difficulty loading course pages. Our engineers are actively investigating.
Posted Jul 22, 2022 - 13:46 EDT
This incident affected: Student Courseware and Checkout.