Courseware slowness
Incident Report for edX
Resolved
This incident has been resolved.
Posted 2 months ago. Jan 15, 2019 - 10:31 EST
Investigating
We are investigating slowness in the Student courseware this morning, we apologize for any inconvenience.
Posted 2 months ago. Jan 15, 2019 - 09:57 EST