Delay in course purchase/upgrade display

Incident Report for edX

Resolved

All purchases have been processed and this issue has now been fully resolved.
Posted Oct 29, 2024 - 23:37 UTC

Update

There is no longer a delay between course purchases and the course appearing on the learner home page. Learners who have recently purchased/upgraded a course should refresh their home page before trying to check out again. If you completed a purchase and are still not seeing your course, no need to repurchase as we're currently working through a queue of purchases. We will update this status when all these purchases have been restored.
Posted Oct 29, 2024 - 19:20 UTC

Monitoring

A fix has been implemented. There is no longer a delay between course purchases and the course appearing on the learner home page. Learners who have recently purchased/upgraded a course should refresh their home page before trying to check out again.
Posted Oct 29, 2024 - 17:45 UTC

Investigating

We are investigating an issue that is resulting in a delay between the time that a course is purchased or upgraded and when that course appears for learners on the learner home page. Learners who have recently purchased/upgraded a course should wait and refresh their home page before trying to check out again.
Posted Oct 29, 2024 - 17:03 UTC
This incident affected: Student Courseware and Checkout.