Degraded performance on edx.org
Incident Report for edX
Resolved
The degraded performance issue on edx.org has been resolved.
Posted Jul 12, 2019 - 14:00 EDT
Monitoring
The degraded performance issue on edx.org has recovered. We are actively monitoring performance on edx.org.
Posted Jul 12, 2019 - 11:01 EDT
Investigating
Edx.org is currently experiencing degraded performance. Our engineers are actively investigating. End users may experience slowness on the edx.org homepage and while making purchases.
Posted Jul 12, 2019 - 10:37 EDT
This incident affected: edX Homepage, Checkout, and Catalog API.