Course slowness
Incident Report for edX
Resolved
This incident has been resolved.
Posted 8 months ago. Jan 15, 2019 - 09:57 EST
Monitoring
We have identified and fixed this issue. We will continue to monitor the system for additional issues.
Posted 8 months ago. Jan 14, 2019 - 14:40 EST
Investigating
We are investigating issues affecting overall performance of student courseware. We are sorry for any inconvenience.
Posted 8 months ago. Jan 14, 2019 - 13:28 EST
This incident affected: Student Courseware.