Most edX functionality unavailable

Incident Report for edX

Resolved

As of 1:25 p.m. UTC, the outage that impacted edX.org learning and authoring functionality, including the edX mobile apps, has been resolved and our systems are fully operational. This outage lasted for approximately two hours. We continue to monitor our systems closely for any signs of instability.
Posted Aug 07, 2025 - 13:30 UTC

Investigating

Nearly all functionality on edX.org, including the learning and authoring experiences, became unavailable as of 11:33 a.m. UTC. The edX mobile apps for Android and iOS are also impacted. Our teams are currently investigating this issue.
Posted Aug 07, 2025 - 13:22 UTC
This incident affected: Student Courseware, Grader Queues, Instructor Analytics, and Course Authoring (Studio).