edge.edx.org outage
Incident Report for edX
Resolved
edge.edx.org is back up
Posted 8 months ago. Nov 08, 2017 - 15:24 EST
Investigating
edge.edx.org is down we are currently investigating
Posted 8 months ago. Nov 08, 2017 - 15:14 EST