Fulfillment Delays

Incident Report for edX

Resolved

Performance of the student courseware is back to normal and stable.
Posted 5 months ago. Sep 13, 2024 - 19:46 UTC

Update

Performance has returned to normal on student courseware. We'll continue to monitor to ensure stability.
Posted 5 months ago. Sep 13, 2024 - 19:38 UTC

Monitoring

We've implemented a fix that requires a rollout over time. Thus, we're continuing to see some performance issues in the student courseware, but they are decreasing. We're currently monitoring until performance fully returns back to normal.
Posted 5 months ago. Sep 13, 2024 - 19:10 UTC

Update

Purchase fulfillment performance is now back to normal. However, downstream effects are still causing slowdowns in the student courseware. We are currently rolling out a fix for this.
Posted 5 months ago. Sep 13, 2024 - 18:24 UTC

Identified

We are noticing reports of delays in learners' enrollment status updating after a purchase. We have identified the issue and are working to bring performance back up to normal speed.
Posted 5 months ago. Sep 13, 2024 - 18:18 UTC
This incident affected: edX Homepage, Student Courseware, and Checkout.