We are experiencing slow performance and high error rates due to Amazon S3
Incident Report for edX
Resolved
This incident has been resolved.
Posted 7 months ago. Mar 20, 2018 - 15:36 EDT
Monitoring
AWS S3 is no longer down. We are continuing to monitor the issue.
Posted 7 months ago. Mar 20, 2018 - 12:14 EDT
Investigating
Amazon S3 is currently experiencing an outage that is resulting in high error rates and slow performance for edx.org
Posted 7 months ago. Mar 20, 2018 - 11:25 EDT