Reduced performance
Incident Report for edX
Resolved
The latency issues appear to have resolved. We have assigned a team to further investigate internally. Thank you for your patience.
Posted 4 months ago. Apr 04, 2018 - 12:53 EDT
Investigating
We are experiencing performance issues, which we are now investigating. We apologize for any inconvenience.
Posted 4 months ago. Apr 04, 2018 - 11:53 EDT